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Welcome to Oloneo PhotoEngine. 

  

Additional Resources 

Along with this user manual, there is a variety of other resources you can use to find out more about 

Oloneo PhotoEngine. 

  

Oloneo Website 

For general information, updates and technical support, as well as the latest news on Oloneo 

PhotoEngine, go to: 

 http://www.oloneo.com 

  

Inside the application 

Video tutorials can be found in the Help Workspace. 

  

Flickr forum 

The official forum for discussing about Oloneo PhotoEngine is hosted on Flickr. The forum is monitored 

by Oloneo so this is the place to easily interact with the development team. Visit: 

 http://www.flickr.com/groups/oloneophotoenginetalk/ 

  

http://www.oloneo.com/
http://www.flickr.com/groups/oloneophotoenginetalk/
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Overview: Main Features 

  

Introduction 

Oloneo PhotoEngine is a professional Raw Photo processing, HDR creation, Tone Mapping and advanced 

image editing software. It is the result of over four years of research and development in Computational 

Photography. 

  

Main features: 

 HDR ToneMap: HDR edition and Tone Mapping in real time 
 HDR ReLight: photo relighting in real time 
 HDR DeNoise: noise reduction without loss of details 
 Raw photo processing 
 Adobe Lightroom plug-in and direct export to Adobe Photoshop 

  

HDR ToneMap™: high dynamic re-exposure in real-time 

A full real-time, high dynamic range (HDR) re-exposure module to merge and edit single or multiple 

RAWs, JPEGs or TIFFs. Capable of creating a wide range of styles, from realistic to artistic, HDR ToneMap 

includes four tone mapping engines, Natural HDR™ processing mode, auto-exposure correction with 

fine-tuning, auto-contrast, detail size and threshold controls, halo control, edge sharpening, ghost 

removal tools, auto-align, auto-orientation, batch processing with interactive mode, over 40 interactive 

factory presets and user-defined presets, and more. You also have the possibility to modify exposure the 

traditional way by turning off tone mapping while still benefiting from a 32-bit, ultra-wide gamut and full 

resolution environment. 

  

HDR ReLight™: take pictures then set-up lighting 

An image-based relighting tool using merged RAWs, JPEGs or TIFFs to control in real-time the settings of 

individual light sources after the photos are taken. For each light source, parameters include white 

balance, brightness, temperature, tint and color. Other features are the auto-detection of ambient light 

and each light source's color temperature. 

  

HDR DeNoise™: remove noise and keep details 

A powerful image noise and grain reduction tool using stacked RAWs, JPEGs or TIFFs, with the added 
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benefits of full detail preservation, no smoothing and no artifacts, even with low-contrast and low-light 

photos. 

  

Complete, high-end RAW photo processing 

Oloneo PhotoEngine also features a complete RAW and image processing module including a 

customizable Color Curve Equalizer™ with hue/saturation, hue/luminance and hue/hue curves, a 

brightness curve, a unique color saturation curve, a color toning tool, an advanced white balance control 

and more. PhotoEngine handles most RAW photo formats, with thumbnail and preservation of key EXIF 

metadata, fully supports color management and uses the ICC profiles generated by most colorimeters 

on the market today. 
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Overview: the User Interface 

  

Introduction 

PhotoEngine uses a tabbed interface to allow you to focus on the task at hand. There are three main 

tasks grouped in three Workspaces: 

 Browsing files and creating projects in the Browse Workspace 
 Editing an image in the Edit Workspace 
 Getting help in the Help Workspace  

  

The Browse Workspace 

This is where PhotoEngine starts. Use the Browse Workspace to: 

 Display and browse your photos 
 Select photos 
 Create an HDR ToneMap, HDR ReLight or HDR DeNoise project 
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The Edit Workspace 

PhotoEngine switches to the Edit Workspace after loading or creating a new project. Use the Edit 

Workspace to: 

 Edit your photos 
 Save the current project 
 Export the edited photo 
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The Help Workspace 

The Help Workspace is where you get help on Oloneo PhotoEngine. Use the Edit Workspace to: 

 Watch tutorial videos 
 Read the user manual 
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Managing the Workspaces 

PhotoEngine automatically switches from workspace to workspace when needed. You can also select 

which Workspace is displayed at any time. 

  

Selecting the Workspace to be displayed: 

 Click on the Browse, Edit or Help buttons located in the top menu bar 
 Or, select Browse, Edit or Help in the Tools menu 
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The Browse Workspace 

  

Overview 

The Browse Workspace is where you display your photos and create new projects. 

  

There are five main areas in the Browse Workspace: 

 1: Browsing toolbar where you select the directory to be displayed 
 2: Photo thumbnails of the currently displayed directory 
 3: Image Info panel showing the currently selected photo 
 4: Project creation panels 
 5: Recent Projects toolbar and panel 
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The Browsing toolbar 

The Browsing toolbar allows you to select the folder displayed by PhotoEngine and to set the size of 

thumbnails. 

There are multiple ways to select an image folder: 

 Direct selection using the system File or Folder Dialog 
 Selecting a recently browsed folder 
 Typing the path of the folder 

  

 

  

Selecting a folder: 

 Click on the “…” button 
 Using the system File Dialog navigate to a folder containing image files 
 Select a file then click the Open button 
 PhotoEngine starts displaying the thumbnails 

  

 

  

Selecting a folder using the menu: 

 Click on the Down Arrow button 
 Click on Browse (Using File Dialog) ... 
 Or, click on Browse (Using Folder Dialog) ... 
 Using the File or Folder Dialog, navigate to your image folder 
 Close the dialog 
 PhotoEngine starts displaying the thumbnails 

  

 

  

Selecting a recent folder using the menu: 
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 Click on the Down Arrow button 
 Select one of the listed folders 
 PhotoEngine starts displaying the thumbnails 

  

 

  

Editing the folder path: 

 Click in the address bar 
 Type or cut and paste the path to your folder 
 Press the Return or Enter key to validate 
 PhotoEngine starts displaying the thumbnails 

  

 

  

Setting the thumbnail size: 

 Click and drag the slider located at the right of the Browsing toolbar 

  

 

  

The Thumbnail list 

After selecting a folder, PhotoEngine displays the photos and project files contained in the folder. There 

are two file categories: 

 PhotoEngine Project files, displayed on a blue background 
 Image files, displayed on a gray background with the file extension displayed at the top left 

corner 
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Opening a project file: 

 Double click on the Project file thumbnail 
 PhotoEngine switches to the Edit Workspace and load the project 

  

Opening a Single JPEG, TIFF, Radiance or Raw file: 

 Double click on the file thumbnail 
 PhotoEngine switches to the Edit Workspace and load the image 

  

Selecting several image files: 

 Scroll the thumbnail list until you see the set of photos you want to use 
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 Click on the first photo in the set 
 Shift-Click on the last photo in the set 

Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 

  

A green frame is displayed around the selected photos. You can create a new project after selecting the 

images. Read the following chapters to learn how to create an HDR ToneMap, HDR ReLight or HDR 

DeNoise project from the selected images. 

  

  

The Image Info panel 

The Image Info panel displays key Exif data of the selected photo. 

  

 

  

  

The project creation panels 

Several panels located at the right of the screen allow you to create new PhotoEngine projects. Read the 

following chapters to learn how to create an HDR ToneMap, HDR ReLight or HDR DeNoise project. 
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The Recent Projects panel 

All the projects that you create or edit are automatically added to the Recent Projects panel located at 

the bottom of the screen. This panel allows you to quickly open and edit a recent project without having 

to locate the folder where the project file is stored. 
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Opening a recent project file: 

 Double click on a project thumbnail located in the Recent Projects panel 
 PhotoEngine switches to the Edit Workspace and load the project 

  

Setting the number of displayed files: 

 Click on the menu located at the top left of the Recent Projects panel 
 Select the number of files to be displayed 
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The Edit Workspace 

  

Overview 

The Edit Workspace is where you edit your photos and projects. 

  

There are five main areas in the Browse Workspace: 

 1: Edited image 
 2: Image Info panel 
 3: Image toolbar 
 4: Image setting panels 
 5: Timeline panel 
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The edited image 

The displayed image is not just a preview. This is the final image with all the settings 

applied.  PhotoEngine has the unique capability of displaying in real time all your changes including Tone 

Mapping. 

  

Seeing the image at full resolution: 

 Click anywhere in the image 
 Click again to zoom back 

  

Panning the image at full resolution: 

 Click anywhere in the image to zoom 
 Click and drag to pan the image 

  

The Info panel 

The Info panel displays the image histogram and the RGB values of the pixel currently under the mouse 

pointer. The histogram is updated in real time and is always up to date. 

  

 

  

The Image toolbar 

The Image toolbar is located at the top of the image. It allows you to zoom, rotate, flip the image and set 

the white balance. 

  

 



Oloneo PhotoEngine 

 

22 

  

Seeing the image at full resolution: 

 Click on the button located at the left of the Image toolbar 
 Click again to zoom back 

  

 

  

Rotating the image: 

 Click on the second or third button located in the Image toolbar 

  

 

  

Flipping the image: 

 Click on the fourth or fifth button located in the Image toolbar 

  

 

  

Using the white balance tool: 

 Click on the Eye Dropper button located in the Image toolbar 
 Click anywhere in the picture to set the neutral point. 
 When done, click again on the Eye Dropper button to turn it off 
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The image setting panels 

The panels located at the right allow you to edit the image settings. The available settings depend on the 

type of project you are working on. Read the following chapters to learn how to edit an HDR ToneMap, 

HDR ReLight or HDR DeNoise project. 
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The Timeline panel 

Everything you do is automatically recorded in the Timeline panel located at the left of the screen. You 

can click on a Timeline level to go back in time and see the image at a previous step of the edition 

process. Read the following chapters to learn how to use the timeline with an HDR ToneMap, HDR 

ReLight or HDR DeNoise project. 
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The Help Workspace 

  

Use the Help Workspace to learn how to use Oloneo PhotoEngine. 

  

 

  

Watching a video tutorial: 

 Click on one of the links located in the Video Tutorials panel 
 PhotoEngine opens a new web page in your default web browser and displays the video 

  

Reading the user manual in a web browser: 

 Click on the Open Page in Browser button located at the top 
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 PhotoEngine opens a new web page in your default web browser 
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User Interface Main Controls 

  

Overview 

PhotoEngine uses several User Interface Controls that are important to master. These main controls 

appear in many places in the user interface. The main controls are: 

 Setting panels 
 Sliders 
 Color Wheels 
 Curve Editors 

  

The Setting Panel 

The Setting Panel is a box that groups related settings. Panels have three main areas: 

 1: Title bar 
 2: Video Help button 
 3: Contents box 

  

You can hide and reveal the contents of a Setting Panel. 

  

 

  

Hiding the contents: 
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 Double click on the Title Bar located at the top of the panel 
 Double click again to unhide 

  

 

  

Getting help: 

 Click on the Video Help button located at the top right of the panel 

  

 

  

The Slider 

The slider allows you to edit a setting using the mouse pointer, the keyboard or by entering a value. 
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Dragging the cursor: 

 Click on the blue slider cursor 
 Drag to change the value 

  

 

  

Dragging the cursor with high accuracy: 

 Hold the Control-key 
 Click on the blue slider cursor 
 Drag to change the value 

  

Moving the cursor with the keyboard: 

 Click on the blue slider cursor 
 Press the keyboard arrows to move the cursor 

  

Entering a value: 

 Click in the numeric box located at the right of the slider 
 Type the value 
 Press the Enter, Return or Tab key to validate 

  

 

  

Resetting a slider to default value: 

 Double-click the numeric box 
 The slider returns to its default value 

  

The Color Wheel 
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The slider allows you to quickly select the tint and saturation of a color. There are three parts in the 

color wheel: 

 1: Tint wheel 
 2: Saturation bar 
 3: Color preview 

  

 

  

Setting the color saturation: 

 Click on the cursor located in the horizontal bar 
 Drag to change the value 

  

 

  

Setting the tint: 

 Click on the cursor located in the circular part 
 Drag to change the value 
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The Curve Editor 

PhotoEngine uses a sophisticated curve editor for high accuracy image editing. 

  

 

  

Adding a point: 

 Click anywhere on the curve 
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You can add up to ten points to a curve. 

  

Deleting a point: 

 Click on an existing point 
 Press the Delete-key 

Or: 

 Right-click on an existing point 
 Select Delete Selected Point in the menu 

  

 

  

Editing the curvature: 

 Click and drag one of the displayed arrows 
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Changing the curve mode: 

 Right-click the curve 
 Select Linear, Catmull-Rom or Bézier Spline Mode in the menu 

  

 

  

The Color Curve Editor 

The Color Curve Editor is similar to the Curve Editor. By default, the curve points can only slide along the 

vertical axis. 
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Changing how points move: 

 Right-click the curve 
 Select Free Mode or Vertical Lock Mode in the menu 
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File Drag and Drop 

  

Instead of using the Browse Workspace to select or open files, you can directly drag and drop images 

from the Windows Explorer to PhotoEngine. 

  

Drag and Drop images to the Image Selection panel: 

 Locate your files using the Windows Explorer 
 Select the images, start drag 
 Drop over the Image Selection Panel in the Browse Workspace 

  

You can drag and drop JPEG, TIFF or Raw photos to the Image Selection Panel. 
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Drag and Drop images to the Browse Workspace: 

 Locate your file using the Windows Explorer 
 Select one image or project file, start drag 
 Drop over Edit Workspace 

  

You can drag and drop JPEG, TIFF, Raw photos, Radiance files and PhotoEngine project files to the Edit 

Workspace. 
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HDR ToneMap: Creating a Project 

  

Overview 

An HDR ToneMap project requires two or more photos. For better results the photos must share the 

same aperture and same ISO. Each of the photos should show the same scene taken at different shutter 

speeds.  

  

The easiest way to achieve that is to set your camera in Aperture Priority mode (Av or A mode) and 

enable the bracketing feature. The three or more photos should cover the entire dynamic range of the 

photographed scene. In other words: 

 The photo with the shortest shutter speed should not contain overexposed highlights 
 The photo with the longest shutter speed should not contain underexposed shadows 

  

A good starting point is to take three photos spaced of 2 EV (Exposure Value). For instance: 

 Photo 1: -2EV, 1/1000s 
 Photo 2:   0EV, 1/250s 
 Photo 3: +2EV, 1/60s 

  

Scenes with a very high dynamic range may require more than three photos.  

  

For high quality results, it is recommended to reduce the Exposure Value and increase the number of 

photos. For instance: 

 Photo 1: -2EV, 1/1000s 
 Photo 2: -1EV, 1/500s 
 Photo 2:   0EV, 1/250s 
 Photo 2: +1EV, 1/125s 
 Photo 3: +2EV, 1/60s 

  

Creating the project is done in four steps: 

 Step 1: locating the folder containing the photos 
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 Step 2: selecting a set of bracketed photos 
 Step 3: adding the set to the Project Image Selection panel 
 Step 4: creating the project 

  

 

  

Step 1, locating the photos 

In order to create a new HDR ToneMap project, you have to first display the photos needed for the 

project in the Browse Workspace. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
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 Click on the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 

  

Step 2, selecting the photos 

  

 

  

Selecting photos: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Click on the first photo in the set 
 Shift-Click on the last photo in the set 
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Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 

  

A green frame is displayed around the selected photos. 

  

Step 3, adding the photos to the project selection panel 

Add the photos selected at the previous step to the Project Image Selection panel. 

Adding photos to the Project Image Selection panel: 

 Select the images as explained in step 2 above 
 Click on the Add button located at the bottom of the Project Image Selection panel 

  

 

  

If the panel already contains photos from a previous project, you have first to clear the Project Image 

Selection list. 

Removing all photos from the Project Image Selection panel: 

 Click the Clear button located at the bottom of the Project Image Selection panel 

Removing one photo from the Project Image Selection panel: 

 Click on one of the small thumbnails located in the Project Image Selection list 
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 Click on the Remove button located at the bottom of panel 

  

You are now ready to create an HDR ToneMap project. 

  

Step 4, creating the HDR ToneMap project 

At this point, PhotoEngine can create the HDR ToneMap Project. The HDR ToneMap panel should 

display: “Ready to create HDR ToneMap Project!” 

  

 

  

HDR ToneMap projects have two options: Auto Align and Ghost Removal. 

  

What is Auto Align? 

If you are not using a tripod the camera may move when bracketing. The Auto Align feature attempts to 

align the photos when assembling the images. 

  

When to use Auto Align? 

Use Auto Align only when taking photos handheld. Never use Auto Align when using a tripod. The 

additional processing always slightly degrades the resulting image. For high quality results, use a tripod 

and turn Auto Align off. 

  

What is Ghost Removal? 

The Ghost Removal feature attempts to detect and remove moving peoples and objects in a set of 

photos.  

  

When to use Ghost Removal? 

Use Ghost Removal only when photographing non static scenes such as: crowds, cars, trees in windy 
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condition, waves, etc. Never use Ghost Removal for static scenes such as: architecture, real estate, 

interior design, etc. The additional processing always slightly degrades the resulting image. 

  

How to help the Ghost Removal feature? 

Ghost Removal is a very complex technology and may fail. For instance, it is not possible to remove 

several moving objects when they overlap across several photos. The reason is that none of the photos 

contains the background. The best way to avoid issues is to increase the number of photos. Instead of 

taking just one set of bracketed photos, you can take two. Though the exposures remain the same for 

the two sets, the additional images give PhotoEngine more data to work with. 

  

What is the difference between Ghost Removal Method 1 and Method 2? 

The two methods use very different approaches to detect and remove moving objects. In most cases, 

Method 2 is superior to Method 1 especially with photos containing many moving objects. By default, it 

is recommended to use Method 2. If Method 2 fails, try Method 1. 

  

Enabling Auto Align: 

 Click on the Auto Align checkbox located in the HDR ToneMap panel 
 Click again on the checkbox to turn it off 

  

 

  

Enabling Ghost Removal: 

 Click on the Ghost Removal menu located in the HDR ToneMap panel 
 Select Method 1 or Method 2 
 Select No Ghost Removal to turn it off 
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After choosing the HDR ToneMap options, you are ready to create the project. 

  

Creating the HDR ToneMap project: 

 Click the Create HDR ToneMap Project button located at the bottom of the HDR ToneMap panel 

  

PhotoEngine automatically switches to the Edit Workspace and starts loading the photos. 

  

What to do when the HDR ToneMap panel displays an error message? 

When your photos do not contain Exif data or have missing Exif data, the HDR ToneMap Panel will 

display an information message such as: “Shutter speed values are required to build an HDR ToneMap 

Project”. 

  

If this happens you can enter missing data by hand. The Project Image Selection panel works like a small 

spreadsheet. You can click in any cells to enter a missing value. 

  

Manually setting missing data: 

 Click in the cell with the missing value in the Project Image Selection panel 
 Type the missing Shutter Speed, F-Number or ISO value 
 Press the Tab key to validate 
 Repeat until all missing values are entered 
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HDR ToneMap: Single Raw Processing 

  

Overview 

HDR ToneMap is also a powerful Raw processing tool. Tone mapping can greatly improve a single Raw 

photo. In addition to Raw files, HDR ToneMap can be created from a single TIFF, JPEG or Radiance file. 

  

Single files supported by HDR ToneMap: 

 Raw Photo 
 8-bit or 16-bit TIFF image 
 JPEG image 
 Radiance 32-bit High Dynamic Range Image file 

  

How to create an HDR ToneMap from a single file: 

 Step 1: locating the folder containing the photo 
 Step 2: double click the photo thumbnail 

  

Step 1, locating the photo 

In order to create a new HDR ToneMap project, you have to first display the folder containing the photo 

you want to process. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
 Click on the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 
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Step 2, creating the project 

Simply double-click on the photo thumbnail to create the project. 

Creating an HDR Project from a single file: 

 Scroll the thumbnail list until you see the photo you want to use 
 Double-click on the photo thumbnail 

  

PhotoEngine automatically switches to the Edit Workspace and starts loading the photo. Read the next 

chapter to learn how to edit an HDR ToneMap project. 

  

Using the file menu 

You can also create an HDR ToneMap project with the File menu. 

Opening a file with the File menu: 

 Press Ctrl-O or select Open... in the File menu 
 In the File Dialog, set the filter to the type of file you want to open: JPEG, TIFF, RAW, Radiance or 

All 
 Using the File Dialog, locate the file  
 Click on the OK button 

  

 

  

PhotoEngine automatically switches to the Edit Workspace and starts loading the photo. Read the next 

chapter to learn how to edit an HDR ToneMap project. 
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HDR ToneMap: Editing a Project 

  

Overview 

To learn how to create an HDR ToneMap project read the previous chapter. After creating or loading a 

project, the image is displayed in the Edit Workspace with default settings. 

  

 

  

When editing an HDR ToneMap project the Edit Workspace contains three main areas: 

 1:  the Timeline and Preset panels on the left of the screen  
 2:  the edited image 
 3:  the Tone Mapping and image settings on the right 

  

To edit the image simply click and drag the various sliders located in the right panels. PhotoEngine 
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automatically updates the image in real-time. 
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HDR ToneMap: Tone Mapping tools 

  

PhotoEngine offers four Tone Mapping tools: 

 Auto Tone Mapper 
 Local Tone Mapper 
 Advanced Local Tone Mapper 
 Global Tone Mapper 

  

What is the Auto Tone Mapper? 

The Auto Tone Mapper uses a single slider to control all the Tone Mapping effects. It uses sophisticated 

algorithms that control Tone Mapping, exposure, contrast, brightness and saturation parameters in a 

fully automated way. Except setting the overall strength of the effect, you have no additional controls.  

  

If you are new to HDR and Tone Mapping, it is probably where you want to start. If you are experienced, 

use the Local Tone Mapper tool which offers more detailed controls.  

  

What is the Local Tone Mapper? 

The Local Tone Mapper is a default Tone Mapping tool. It offers a right balance between control and 

complexity. 

  

What is the Advanced Local Tone Mapper? 

The Advanced Local Tone Mapper is similar to the Local Tone Mapper but adds even more options. It is 

the tool of choice for the advanced and expert users.  

  

What is the Global Tone Mapper? 

The Global Tone Mapper offers an entirely different approach to Tone Mapping. Use it for medium 

dynamic range images and when you are looking for natural results. Images produced with the Global 

Tone Mapper tend to be soft with low contrast. 

  

What is the best tool to use? 

All of them! PhotoEngine always work in real time. You can switch instantly from one tool to the other. 
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Whether an expert user or not, try not to stick to a single workflow. Explore the possibilities: you will be 

pleased by what you discover! 

  

Selecting the Tone Mapping tool: 

 Click on the Menu located at the top of the High Dynamic Tone Mapping panel 
 Select the tool you want to use 

  

 

  

PhotoEngine immediately updates the image and displays the options of the selected tool. 

  

Remark: 

You can entirely turn off the Tone Mapping module by selecting None. Use this option when you want to 

edit the image the traditional way using exposure, brightness, contrast and curves while still benefiting 

from the high precision of the 96-bit per pixel rendering engine. 
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HDR ToneMap: Auto Tone Mapper 

  

Overview 

The Auto Tone Mapper works in an entirely automated way. Use it if you are new to HDR and Tone 

Mapping. With only one setting to play with, it is fun and easy to use. When you have gained more 

experience, you can switch to the Local Tone Mapper which gives more control. 

  

The Auto Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Auto Tone 

Mapper is selected in the menu located at the top.  

  

 

  

Using the Auto Tone Mapper 

The Auto Tone Mapper is easy to use. Simply drag the Strength slider and watch the image change in 

real time. 

  

Editing the Tone mapping setting: 

 Drag the Strength slider 
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Strength value range: 

 0 to 100: low Tone Mapping effect, medium high light recovery, natural image 
 100 to 150: medium Tone Mapping effect, full highlight and shadow recovery, natural image 
 150 to 200: high Tone Mapping effect, full highlight and shadow recovery, detail increase 
 200 to 300: extreme Tone Mapping effect, unnatural image 
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HDR ToneMap: Local Tone Mapper 

  

Overview 

The Local Tone Mapper is the default Tone Mapping tool. It is selected by default when creating a new 

project. 

The Local Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Local 

Tone Mapper is selected in the menu located at the top. The settings are grouped in three categories: 

 Tone Mapping settings 
 Exposure settings 
 Contrast settings 

  

 

  

Main Tone Mapping settings 

The main Tone Mapping settings are controlled by the TM Strength and Detail Strength sliders. 

  

Editing the Tone mapping settings: 

 Drag the TM Strength slider 
 Drag the Detail Strength slider 
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What is TM Strength? 

TM Strength stands for Tone Mapping Strength. It is the Tone Mapping master control. Increase the 

value to reduce global image contrast while keeping the detail contrast unchanged.  The higher the 

value the more you will recover burned highlights and underexposed shadows. 

  

TM Strength values: 

By default the value is 0 meaning no Tone Mapping. The image is displayed “as is”. For most images, use 

values from 0 to 65. In this range, Tone Mapping varies from low to fairly high while maintaining a 

natural image. For special effects, use values from 65 to 100. Around 85 the Tone Mapping becomes 

extreme with global contrast near to zero. High values usually require an increase in Detail Strength. 

Summary: 

 0: default value, no Tone Mapping 
 0 to 65: regular range, low to high Tone Mapping, natural rendering 
 65 to 100: high to extreme Tone Mapping, special effects 

  

TM Strength value can become negative?! 

Absolutely and it is a unique feature! For negative values, PhotoEngine switches to a special mode and 

applies an Anti-Tone Mapping to the image. This mode is usually needed for very peculiar applications 

such as artificially increasing the Dynamic Range of a low dynamic image or for special effects. 

  

Anti-Tone Mapping can bring interesting effects to black and white photos. With it, you can easily add a 

film noir effect to your black and white photos. 
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What is Detail Strength? 

Detail Strength controls the detail contrast (also called micro contrast). Increasing its value will increase 

details visibility.   

  

Detail Strength values: 

By default the value is 0 meaning that the image details are unchanged. For most images, leave the 

value to zero or slightly increase it up to 100. In this range, detail contrast varies from low to medium 

and maintains a natural image. For special effects, use values from 100 to 300. High values are useful to 

create busy images with a high level of detail (the “grunge effect”). 

  

Summary: 

 0: default value, image details are unchanged 
 0 to 100: regular range, low to medium details, natural rendering 
 100 to 300: medium to extreme details, special effects 

  

Detail Strength value can become negative?! 

Yes and it is again a unique feature! For negative values, PhotoEngine actually removes details from the 

image. At -100, all image details are removed. Use this special value range for impressionist effects, to 

simulate old photos, to create soft, ethereal black and white photos, etc. 

  

Exposure settings 

Exposure settings are controlled by the Auto-Exposure checkbox and the Exposure and Fine Exposure 

sliders. 

  

Editing the Exposure settings: 

 Turn on or off Auto-Exposure by clicking the Auto-Exposure checkbox 
 Drag the Exposure slider 
 Drag the Fine Exposure slider 
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What is Auto-Exposure? 

By default, PhotoEngine automatically computes the best possible exposure. The exposure is changed 

when you modify the TM Strength and Detail Strength values. In most cases, leave the Auto-Exposure 

enabled.  

  

Auto-Exposure may fail when working with photos incorrectly bracketed or with severely underexposed 

images. In that case, disable Auto-Exposure and set the exposure manually with the Exposure and Fine 

Exposure sliders. 

  

What is Exposure and Fine Exposure? 

The Exposure and Fine Exposure sliders allow you to correct the exposure that was automatically 

computed by PhotoEngine. For most images, the Exposure slider should remain unchanged unless you 

disable Auto-Exposure. Use the Fine Exposure to fine tune exposure after using TM Strength and Detail 

Strength. 

  

Contrast settings 

Contrast settings are controlled by the Auto-Contrast checkbox and the Contrast slider. 

  

Editing the Contrast settings: 

 Turn on or off Auto-Contrast by clicking the Auto-Contrast checkbox 
 Drag the Contrast slider 
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What is Auto-Contrast? 

By default, PhotoEngine automatically computes the best possible contrast. The contrast is changed 

when you modify the TM Strength and Detail Strength values. You should leave the Auto-Contrast 

enabled in most situations.  

  

Auto- Contrast may fail when working with photos incorrectly bracketed or with severely underexposed 

images. In that case, disable Auto- Contrast and set the contrast manually with the Contrast slider. 

  

What is Contrast? 

The Contrast slider allows you to correct the contrast that was automatically computed by PhotoEngine. 

Use the Contrast slider to fine tune contrast after using TM Strength and Detail Strength. 
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HDR ToneMap: Advanced Local Tone Mapper 

  

Overview 

The Advanced Local Tone Mapper offers expert settings and allows a finer control of Tone Mapping. Use 

the Advanced Local Tone Mapper after mastering the Local Tone Mapper and when you need to fine 

tune a Tone Mapped image. 

  

The Advanced Local Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when 

Advanced Local Tone Mapper is selected in the menu located at the top. The settings are grouped in 

four categories: 

 Tone Mapping settings 
 Exposure settings 
 Contrast settings 
 Advanced settings 

  

The Tone Mapping, Exposure and Contrast settings are equivalent to the settings found in the Local 

Tone Mapper. Read the Local Tone Mapper section to learn more about these settings. 

  

The advanced settings allow you to: 

 Fine tune the image details 
 Modify sharpening 
 Enable the 360 degrees panorama mode 
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Detail settings 

The Detail settings are controlled by the Detail Size and Detail Threshold sliders. 

  

Editing the Detail settings: 

 Drag the Detail Size slider 
 Drag the Detail Threshold slider 
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What is Detail Size? 

In the Tone Mapping process, PhotoEngine needs to classify the various elements of the image. There 

are two main categories: image details (such as: object texture, grass, tree leaves, etc.) and large objects 

(such as: sky, ground, building, etc.). The Detail Size defines what is classified in the image as details. 

When Detail Size is set to a small value, PhotoEngine classifies only the smallest objects in the scene as 

details. 

  

What is Detail Threshold? 

In addition to object sizes, PhotoEngine also uses the local luminance variations to categorize the 

various elements of a photo. The Threshold slider controls that process. When set to a small value, 

PhotoEngine takes into account small luminance variations. For large values of Threshold, PhotoEngine 

ignores small luminance fluctuations. 

  

When should I use Detail Size and Threshold? 

Detail Size and Threshold have no effect when TM Strength and Details Strength are both set to zero. To 

use Detail Size and Threshold you have first to set the TM Strength and Details Strength values. 

  

For most images, TM Strength and Details Strength should remain unchanged. Change the values when 

the image shows excessive halos or to control image detail rendering. 
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How to edit Detail Size and Threshold? 

Detail Size and Threshold are truly advanced features and can be difficult to grasp. Sometimes the best 

method is to use an empirical approach: 

 Set Detail Size to an arbitrary value 
 Then, drag the Detail Threshold slider back and forth 
 Examine the effect obtained and repeat the process by changing the Detail Size 

  

As you gain more experience, you should be able to better understand how these settings affect an 

image. 

  

A useful tip: 

Detail Size and Threshold effect can be quite subtle. In order to better see what you are doing, do the 

following: 

 Edit TM Strength and Detail Strength until you are satisfied with the image.  
 Temporarily increase Detail Strength to a high value 
 Edit Detail Size and Threshold 
 Restore Detail Strength to its previous value 

  

Edge Sharpen 

Editing the Edge Sharpen setting: 

 Drag the Edge Sharpen slider 
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What is Edge Sharpen? 

Edge Sharpen sets the local contrast around object edges. A low value reduces the edge contrast. Edge 

Sharpen also controls gradient reversal. Gradient reversal is an excessive Tone Mapping effect appearing 

around objects with extreme luminance variations such as a window frame taken from the inside of a 

dark room. 

  

How to edit Edge Sharpen? 

As the Edge Sharpen acts at the pixel level, it is recommended to zoom in the image before editing. 

  

Panorama Mode 

When working on a 360 degrees equirectangular panorama, the left and right borders of the image are 

the same. Enabling the Panorama Mode forces PhotoEngine to keep the borders the same. This feature 

allows the Tone Mapping of seamless panoramas. 

  

Editing the Panorama Mode setting: 

 Turn on or off the Panorama Mode by clicking the Panorama Mode checkbox 
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HDR ToneMap: Global Tone Mapper 

  

Overview 

The Global Tone Mapper offers an entirely different approach to Tone Mapping. Use it for medium 

dynamic range images and when you are looking for natural results. Images produced with the Global 

Tone Mapper tend be soft with low contrast. 

  

The Global Tone Mapper settings are displayed in the High Dynamic Tone Mapping panel when Global 

Tone Mapper is selected in the menu located at the top. The settings are: 

 Strength 
 Compression 

  

 

  

Working with the Global Tone Mapper 

The Global Tone Mapper works in two steps: 

 Highlight recovery with the Strength slider 
 Shadow recovery with the Compression slider 

  

Step 1: Highlight recovery 

Increase the Strength value to reveal details in the highlights. 

  

Step 2: Shadow recovery 

Increase the Compression slider to reveal details in the shadows. 
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Remark: 

The Global Tone Mapper works best with medium dynamic range photos. Use it when you want a soft 

and natural Tone Mapping effect. As the effect is much lighter than the other Tone Mapping tools, the 

image will tend to have a low contrast. Use the Low Dynamic Tone panel to modify Exposure, Brightness 

and Contrast. 

  

Editing the settings: 

 Drag the Strength slider 
 Drag the Compression slider 
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HDR ToneMap: the Natural HDR Mode 

  

Overview 

The Natural HDR Mode is the result of years of research in Tone Mapping, image processing, color 

theory and psychophysiology. This feature is unique to Oloneo PhotoEngine. Unlike other products, the 

Natural HDR Mode is not just based on mathematical algorithms. It is a mix of sophisticated algorithms 

and empirical corrections based on how humans perceive color, brightness and contrast. 

  

In order to get always the most natural results, the Natural HDR Mode is actually built-in PhotoEngine 

and always running.  The Natural HDR Mode checkbox allows you to turn the effect entirely on or 

partially off. 

  

Using the Natural HDR Mode 

  

Enabling or disabling the Natural HDR Mode: 

 Click on the Enable checkbox located in the Natural HDR Mode panel 

  

 

  

When to use the Natural HDR Mode? 

Most images can benefit from the Natural HDR Mode when you are looking for a natural result. 

  

Natural HDR Mode and Raw processing: 

The Natural HDR Mode combined with light Tone Mapping can have a dramatic effect on your Raw 

photos. Try it, you won’t be disappointed! 

  

When not to use the Natural HDR Mode? 
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Turn it off when you want to create images with very high contrast and saturation. 

  

When working with Raw photos of monochromatic scenes or with muted colors, the Natural HDR Mode 

may apply too strong a correction. 

  

How come the Natural HDR Mode has no effect on my photo? 

The effect is highly dependent on the photo and the settings you are using. PhotoEngine may find that 

the particular setting and photo you are using do not need a correction to look natural. Also, the effect 

can be quite subtle and imperceptible at first glance. The Natural HDR Mode is usually more obvious on 

photos with saturated colors and fairly high Tone Mapping settings. 
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HDR ToneMap: Basic Image Settings 

  

Low Dynamic Tone settings 

When you are done with Tone Mapping, you can start working on general image settings: Brightness, 

Contrast, Saturation and White Balance. 

  

Editing key image settings: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Click and drag the Exposure, Brightness, Contrast and Saturation sliders. 
 For high precision edition, hold Control-Key while dragging a slider. 

  

 

Editing white balance: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Use the Temperature, Tint sliders, Color Wheel or the Illuminant local menu. 
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Setting white balance with the Eye Dropper: 

 Click on the Eye Dropper icon located in the top tool bar 
 Click anywhere in the picture to set the neutral point. 
 When done, click again on the Eye Dropper icon to turn it off 
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HDR ToneMap: Advanced Image Settings 

  

Photographic Print Toning 

Photographic Print Toning simulates a chemical process that replaces the silver contained in the photo 

emulsion by a toner or another metal. This process usually adds two tones to black and white 

photographic prints: one for the deep shadows and one for the highlights. Popular print tonings are: 

sepia, selenium, gold and platinum. 

  

Unlike the real world process, the Photographic Print Toning in PhotoEngine can also work with color 

photos. 

  

Enabling Photographic Print Toning: 

 Scroll the panels located on the right of the screen to display the Photographic Print Toning 
panel 

 Click on the Enable checkbox located at the top left of the panel 
 Click again to disable 

  

 

  

Editing shadow and highlight tones: 

 Click and drag the horizontal slider of the left Color Wheel slider to set the shadow saturation 
 Click and drag the circular slider of the left Color Wheel slider to set the shadow hue 
 Click and drag the horizontal slider of the right Color Wheel slider to set the highlight saturation 
 Click and drag the circular slider of the right Color Wheel slider to set the highlight hue 
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First set the Saturation slider to zero to simulate the regular print toning of a black and white photo. The 

Saturation slider is located in the Load Dynamic Panel. 

  

Editing shadow and highlight Mix: 

 Drag the Mix slider located at the bottom of the panel 

  

 

  

The Mix value defines the balance between shadow and highlight toning. When Mix has a negative 

value, most of the image is toned with the shadow tone.  When Mix has a positive value, most of the 

image is toned with the highlight tone. 

  

  

Brightness Curve 
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The Brightness Curve is a powerful tool. Use it to fine tune the shadow, mid and highlight tones of your 

image. 

  

Editing brightness curve: 

 Scroll the panels located on the right of the screen to display the Brightness/Brightness curve 
 Click anywhere in the curve to add a new point 
 Drag a point or a tangent (arrow) to change the shape of the curve. 
 To delete a point, click on a point and press the Delete-key or right-click and select Delete 

Selected Point 

  

 

  

Trick: 

If you want to work on the shadows only, add one or two points to the middle and top portions of the 

curve. This will lock the upper part of the curve. Do the reverse when working on the highlights. 

  

  

Saturation Curve 

The Saturation Curve is a unique feature of PhotoEngine. Conceptually, it works like a regular brightness 

curve but in the saturation domain. The input is the original saturation of the image (horizontal axis). 

The output is the edited saturation (vertical axis). The shape of the curve determines how the input 

saturation is mapped to the output saturation. 
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The bottom left of the curve controls the pixels with a low saturation; the upper right portion controls 

pixels with a high saturation. Here is an example: 

 Click on the middle of the curve to add a point 
 Drag the top right tangent to an horizontal position 
 Drag the top right point to the bottom 

  

The shape of the curve (see screen shot below) now maps highly saturated pixels to de-saturated ones. 

This means that saturated pixels are now in black and white. 

  

By editing other sections of the curve, you can selectively saturate or de-saturate portions of the edited 

image. 

  

Editing the saturation curve: 

 Scroll the panels located on the right of the screen to display the Saturation/Saturation curve 
 Click anywhere in the curve to add a new point 
 Drag a point or a tangent (arrow) to change the shape of the curve. 
 To delete a point, click on a point and press the Delete-key or right-click and select Delete 

Selected Point 
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Color Equalizer 

The Color Equalizer works just like an audio equalizer. Instead of modifying bass or treble, it acts on the 

various hues of the edited photo. The Color Equalizer can create a large range of effects. Here are a few 

examples: 

 Decrease the brightness of a blue sky without affecting the other colors of the photo 
 Slightly de-saturate a lawn that appears too green (a common occurrence) 
 Convert a photo to black and white except for objects with a red hue. 
 Shift the color of car from blue to red 

  

The Color Equalizer is split into three parts: 

 Hue/Saturation 
 Hue/Luminance 
 Hue/Hue 
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Hue/Saturation: 

Use the Hue/Saturation curve to increase or decrease the saturation of pixels with a given hue. 

  

Hue/Luminance: 

Use the Hue/Luminance curve to increase or decrease the luminance of pixels with a given hue.  

  

Hue/Hue: 

Use the Hue/Luminance curve to shift the pixels with a given hue to another hue, such as orange to red, 

blue to green, etc. 

  

Editing the Hue/Saturation curve: 

 Scroll the panels located on the right of the screen to display the Hue/Saturation curve 
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 Drag a point vertically to change the shape of the curve. 

  

 

  

The Hue/Luminance and Hue/Hue curves work the same way. 

  

To learn more about curve edition, read: User Interface Main Controls.  

  

Comment: 

The Color Equalizer is also a powerful tool to convert a photo to black and white. The process is as 

follows: 

 First set the Saturation slider to zero to convert to black and white 
 Use the Hue/Luminance curve to increase or decrease the luminance based on the original color 

  

With this approach you can, for instance, darken a blue sky in a black and white photo. 
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HDR ToneMap: Presets 

  

PhotoEngine includes over 40 factory presets. Use this preset library to quickly modify all the settings of 

an image. The Preset panel is located at the bottom left corner of the screen. 

  

Using presets is also a good way to learn how to use PhotoEngine. Apply a preset and then look at the 

various image settings.  

  

 

  

The Preset panel allows you to: 

 Preview a preset 
 Apply a preset 
 Add a new preset 
 Delete a preset 
 Edit a preset 
 Sort presets 
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Previewing a preset: 

 Move the mouse pointer without clicking over any preset located in the Preset panel 
 PhotoEngine immediately updates the image with the preset settings 
 Move the pointer away to restore the current settings 

  

 

  

Applying a preset: 

 Click on a preset located in the Preset panel 
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Adding a new preset: 

 Click on the Add button located at the top of Preset panel 
 The New  Preset dialog opens 
 Enter the Preset Name 
 Select the Category 
 Click the Favorite checkbox to add the preset to your Favorite list 
 Click the Locked checkbox to protect the preset against deletion 
 Click the OK button to create and save the preset 
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Deleting and editing a preset: 

 Right-click on a preset located in the Preset panel 
 To delete, select Delete Preset in the menu 
 To edit, select Edit... in the menu 
 To add/remove from favorites, select Favorite in the menu 

  

 

  

Comment: 

You cannot delete locked presets. To delete, first select Edit..., uncheck the Locked checkbox, click OK; 
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then select Delete. 

  

Sorting presets: 

 Click on the Category Menu located at the top of the Preset panel 
 Select a category 
 Select the All category to show all presets 
 Select the User Presets category to show you own presets 
 Select the Favorite category to show your favorite presets 
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HDR ToneMap: Batch Processing 

  

Overview 

The Batch feature allows you to process a large number of photos in an automated way. With this 

feature you can do the following: 

 Process a large number of Raw photos in a fully automated way or with an interactive preview 
to fine tune the settings 

 Build a number of HDR images from a series of bracketed photos and apply Tone Mapping 
settings automatically 

  

After processing, the Batch processing saves each image in the file format of your choice. 

  

Batch creation 

The first step is to create a new batch and edit its settings. 

  

Creating a new Batch: 

 Select Batch... in the File menu. 
 If you have unsaved work, PhotoEngine will offer to save your photo 
 The Batch Dialog is displayed 

  

Batch creation, selecting the Source Directory: 

 Click the Browse... button located in the Source panel 
 Using the Directory Dialog, select the directory containing your photos 
 Click OK 
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Batch creation, selecting the Destination Directory: 

 Click the Browse... button located in the Destination panel 
 Using the Directory Dialog, select the directory that will contain the processed photos  
 Click OK 
 Click on the Image Format menu to select the file format of the saved images (TIFF or JPEG) 
 Select the file format options 
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Batch creation, file selection: 

 Select the type of file to use in the menu located at the top of the HDR ToneMap panel 
 Set the number of exposures per project  

  

Example: 
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Let’s say that your Source Directory contains a mix of Raw and JPEG files and that the photos are series 

of three images bracket sets. Select the following settings (assuming you want to use the Raw photos): 

 Image files to use: RAW 
 Number of exposures per project: 3 

  

 

Batch creation, project settings: 

 Click the Auto-Align checkbox to enable Auto-Align 
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 Select the Ghost Removal option 

  

Read the HDR ToneMap: Creating a Project for more info. 

  

 

  

Batch creation, selecting a preset: 

 To use a preset, click the Use Preset checkbox located at the bottom of the HDR ToneMap panel   
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 Select the preset to use in the Preset list located at the right 

  

 

  

Running the Batch 

The PhotoEngine Batch offers two modes: 

 Fully automated mode 
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 Interactive mode 

  

In fully automated mode, PhotoEngine loads one image or a set of images, applies the settings, save the 

image and then moves to the next set of images. The cycle is repeated until all images in the source 

directory are processed. 

  

In interactive mode, PhotoEngine waits before saving the photo to allow you to review the image 

settings before proceeding to the next one. 

  

Selecting the mode: 

 Click on the Interactive checkbox located in the Batch Mode panel 
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Running the Batch: 

 Click the OK button to start the batch 
 The Batch dialog closes and the batch starts running 

  

Fully automated mode: 

The batch runs without interruption. You can cancel the processing by clicking the Cancel button that 
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appears at the top of the Edit Workspace. 

  

Interactive mode: 

The Batch loads the first set of images, processes the project and waits for your input: 

 Click the Continue button to save the image and process the next one 
 Click the Skip button to proceed to the next image without saving the current one 
 Click the Cancel button to stop the batch without saving 
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HDR ToneMap: the Timeline 

  

As with all PhotoEngine projects, everything you do is automatically recorded in the Timeline panel 

located at the left of the screen. You can click on a Timeline level to go back in time and see the image at 

a previous step of the edition process. 

  

 

  

The Timeline is saved in the PhotoEngine project files (.rcd). Your changes are never lost. By reloading 

the project file later on, you will recover all your edition history. 

  

Selecting a previous level in the Timeline: 

 The latest change is displayed at the top of the Timeline list 
 The original image is displayed at the bottom of the list 
 Click anywhere in the list to restart from a previous step. All steps above the selected level will 

be deleted at the next change (in case of a mistake, this can be undone by pressing Control-Z) 
 To restart from scratch, select the first level at the bottom 
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It is worth spending a bit of time mastering the Timeline! The Timeline can greatly increase your 

productivity later on. 

  

PhotoEngine also works as a regular application with undo/redo: 

 Press Control-Z or use the Edit > Undo menu to undo a change 
 Press Control-Y or use the Edit > Redo menu to redo 
 To undo several changes, press Control-Z several times 

  

Comparing images with the Timeline: 

 Check the Interactive Preview checkbox located at the top of the Timeline panel 
 Move the mouse pointer, without clicking, over any Timeline levels 
 PhotoEngine immediately updates the image based on the level’s settings 
 By moving the mouse pointer up and down along the Timeline panel you can visually compare 

different image settings. 
 By moving the mouse pointer inside and outside of the Timeline panel you can visually compare 

the current settings with a previous one, including the original picture (last line at the bottom of 
the Timeline). 
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Adding a version: 

 Click on a level in the Timeline list 
 Click the Add Version button located at the top of the Timeline panel 

  

 

  

This feature is especially useful for HDR ReLight projects. Use it to record different light setups for a 

given photo.  
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Re-playing the Timeline: 

 Click the Play! button located at the top of the Timeline panel 
 Press the Escape key to stop the animation. 

  

 

  

You have worked hard on that project! Enjoy watching all your changes in one short animation. 
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HDR ToneMap: Saving and Exporting 

  

If you plan to work again on the current project, it is critical to save the project as a PhotoEngine project 

file (.rcd file). If you do not plan to work again on the project, you can simply export the final image 

without saving the PhotoEngine project (not recommended). 

  

The PhotoEngine project file provides the following benefits: 

 Full edition history (Timeline) is saved and restored at next load 
 Nondestructive edition. The PhotoEngine project file contains a reference to your original 

photos: your original photos are never modified by the application 
 Project files are small and are saved instantaneously 

  

Saving the project: 

 Press Ctrl-S or select Save in the File menu 
 The current project file is overwritten with the current settings 
 When the project file is new, a file dialog will appear to allow you to name the project file 

  

 

  

Renaming and saving the project: 

 Press Ctrl-Shift-S or select Save As... in the File menu 
 In the File Dialog, select: PhotoEngine file (*.rcd) 
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 Enter the file name 
 Click the Save button 

  

 

  

  

In order to further edit the image in another tool, to publish it online or other tasks, you need to export 

it in a standard format.  

  

Exporting to TIFF or JPEG: 

 Press Ctrl-Shift-S or select Save As… in the File menu 
 In the File Dialog, select: TIFF (*.tif) or JPEG (*.jpg) 
 Enter the file name 
 Click the Save button 
 Select  the TIFF or JPEG settings 
 Click the OK button 
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Direct export to TIFF: 

 Press Ctrl-T or select Export > To Tiff... in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 

  

 

  

Direct export to JPEG: 

 Press Ctrl-J or select Export > To Jpeg... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 
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 Click the OK button 

  

 

  

Exporting directly to an external editor: 

 Press Ctrl-E or select Export To My Tool... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the save settings 
 Click the OK button 

  

 

  

By default PhotoEngine exports to Adobe® Photoshop ®. You can select a different external editor by 

selecting External Editor Preferences... in the Edit menu. 
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To learn more about export options, read: Image Export Options. 
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HDR ReLight: Creating a Project 

  

Overview 

An HDR ReLight project requires from two to six photos. The photos must share the same exposure 

values (shutter speed, aperture and ISO) and the same white balance. Each of the photos should show 

the same scene under a different illumination.  

  

Creating the project is done in four steps: 

 Step 1: locating the folder containing the photos 
 Step 2: selecting a set of photos 
 Step 3: adding the set to the Project Image Selection panel 
 Step 4: creating the project 
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Step 1, locating the photos 

In order to create a new HDR ReLight project, you have first to display the photos needed for the project 

in the Browse Workspace. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
 Click the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 

  

Step 2, selecting the photos 
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Selecting photos: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Click on the first photo in the set 
 Shift-Click on the last photo in the set 

Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 

  

A green frame is displayed around the selected photos. 
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Step 3, adding the photos to the project selection 

Add the photos selected at the previous step to the Project Image Selection panel. 

  

 

  

Adding photos to the Project Image Selection panel: 

 Select the images as explained in step 2 above 
 Click on the Add button located at the bottom of the Project Image Selection panel 

  

If the panel already contains photos from a previous project, you have first to clear the Project Image 

Selection list. 

  

Removing all photos from the Project Image Selection panel: 

 Click on the Clear button located at the bottom of the Project Image Selection panel 

  

Removing one photo from the Project Image Selection panel: 

 Click on one of the small thumbnails located in the left column of the Project Image Selection list 
 Click on the Remove button located at the bottom of the panel 

  

Now that you have added your photos in the Project Image Selection panel you are ready to create a 

HDR ReLight project. 
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Step 4, creating a HDR ReLight project 

At this point, PhotoEngine can now create a HDR ReLight Project. The HDR ReLight panel should display: 

“Ready to create HDR ReLight Project!” 

  

 

  

Creating the HDR ReLight project: 

 Click on the Create HDR ReLight Project button located at the bottom of the HDR Relight panel 

  

PhotoEngine automatically switches to the Edit Workspace and starts loading the photos. Read the next 

chapter to learn how to edit an HDR ReLight project. 

  

What to do when the HDR ReLight panel displays an error message? 

If your photos do not contain Exif data or have missing Exif data, the HDR ReLight Panel will display an 

information message such as: “Shutter speed values are required to build an HDR ReLight Project”. 

  

When this happens you can enter the missing data by hand. The Project Image Selection panel works 

like a small spreadsheet. You can click in any cells to enter a missing value. 

  

Manually setting the missing data: 

 Click in the cell with the missing value in the Project Image Selection panel 
 Type the missing Shutter Speed, F-Number or ISO value 
 Press the Tab key to validate 
 Repeat until all missing values are entered 
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HDR ReLight: Editing a Project 

  

To learn how to create a HDR ReLight project read the previous chapter. After creating or loading a 

project, the image is displayed in the Edit Workspace with default settings. 

  

 

  

When editing an HDR ReLight project the Edit Workspace contains three main areas: 

1:  the Timeline panel on the left of the screen  

2:  the edited image displayed in the center 

3:  the light sources and image settings on the right 

  

To edit the image simply click and drag the various sliders located in the right panels. PhotoEngine 

automatically updates the image in real-time. 
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Editing light sources 

When creating the project, PhotoEngine automatically detects the color, temperature, intensity of the 

scene light sources, ambient light and shadows. These values are displayed in the Light Sources panel. 

  

The Light Sources panel provides unique features such as: 

 Turning on and off light sources  
 Modifying the white balance of each individual light sources without affecting the other ones 
 Fine tuning the light intensity of each light sources 
 Turning a daylight scene into a night photo! 

  

The Light Sources panel is divided into two to six sub-panels, one for each light source. The number is 

equal to the number of photos used to create the project. 
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When PhotoEngine has detected that the scene has ambient light (for instance coming from a window), 

the sub-panels are listed as follows: 

 Ambient Light 
 Light 1 
 Light 2 
 ... 

  

When no ambient light is detected, the list of sub-panels is: 

 Light 1 
 Light 2 
 Light 3 
 ... 
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To edit an individual light source, select one of the sub-panels and modify the settings.  

  

Editing light source intensity: 

 Scroll the Light Source panel to see one of the sub-panels such as: Ambient Light, Light 1, Light 2, 
etc. 

 Drag the top slider located at the right of the sub-panel name 
 A value of 0% turn the light source completely off 
 A value of 100% restore the original light intensity 

  

 

  

Editing light source temperature and tint: 

 Scroll the Light Source panel to see one of the sub-panels such as: Ambient Light, Light 1, Light 2, 
etc. 

 Drag the Temperature and Tint sliders 

  

 

  

Remark: 

The Temperature and Tint sliders allow you to directly define the light source color physical appearance. 

When you set the Temperature to 2800K, the edited source will light the scene like a real Tungsten light 

with a warm color would do. This is the reverse of White Balance edition where the goal is to neutralize 
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the color cast of light sources.  

  

This feature is very powerful. By changing the Temperature and Tint of individual light sources, you 

can: 

 Transform an original fluorescent light into a tungsten one or any other combinations 
 Remove color casts in scenes lighted by a combination of different light sources such as: 

daylight, tungsten and fluorescent 
 Transform a scene taken at noon in a late afternoon or early morning photo by editing the 

ambient light temperature 

  

 Setting the light source color to a normalized illuminant: 

 Scroll the Light Source panel to see one of the sub-panels such as: Ambient Light, Light 1, Light 2, 
etc. 

 Click on the Illuminant local menu 
 Choose one of the illuminant such as: A, D55, D75, F3, etc. 
 Choose As Shot to restore the original light source color 

  

 

  

Directly editing the light source color: 

 Scroll the Light Source panel to see one of the sub-panels such as: Ambient Light, Light 1, Light 2, 
etc. 

 Step 1: click and drag the horizontal slider of the Color Wheel  to increase the saturation 
 Step 2: click and drag the circular slider of the Color Wheel  to choose the color 
 The light color is previewed  in the color swatch located at the top right of the Color Wheel 
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With this feature you can create creative light setups with highly saturated colors. This is often useful 

when photographing objects for catalogs, industrial applications, interior design, etc. Interesting effects 

can be obtained by using complementary colors such as blue/cyan and orange for light sources coming 

from opposite directions. 

  

Editing Image settings 

When you are done with light setup, you can start working on general image settings with the Low 

Dynamic Tone and Brightness Curve panels.  

  

Editing key image settings: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Click and drag the Exposure, Brightness, Contrast and Saturation sliders 
 For high precision edition, hold the Control-Key while dragging a slider 
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Editing the white balance: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Use the Temperature, Tint sliders, Color Wheel or the Illuminant local menu (As Shot, Daylight, 

Tungsten, etc.). 

  

 

  

Setting the white balance with the Eye Dropper: 

 Click on the Eye Dropper icon located in the top tool bar 
 Click anywhere in the picture to set the neutral point 
 When done, click again on the Eye Dropper icon to turn it off 
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Remark: 

White Balance settings affect all the light source colors. This should be your last step after editing the 

light source colors. Doing the reverse can make the light source edition confusing. 

  

Using the brightness curve: 

 Scroll the panels located on the right of the screen to display the Brightness Curve panel 
 Click anywhere in the curve to add a new point 
 Drag a point or a tangent (arrow) to change the shape of the curve 
 To delete a point, click on a point and press the Delete-key or right-click and select Delete 

Selected Point 
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To learn more about curve edition, read: User Interface Main Controls.  

  

  



Oloneo PhotoEngine 

 

117 

HDR ReLight: the Timeline 

  

As with all PhotoEngine projects, everything you do is automatically recorded in the Timeline panel 

located at the left of the screen. You can click on a Timeline level to go back in time and see the image at 

a previous step of the edition process. 

  

 

  

The Timeline is saved in the PhotoEngine project files (.rcd). Your changes are never lost. By reloading 

the project file later on, you will recover all your edition history. 

Selecting a previous level in the Timeline: 

 The latest change is displayed at the top of the Timeline list 
 The original image is displayed at the bottom of the list 
 Click anywhere in the list to restart from a previous step. All steps above the selected level will 

be deleted at the next change (in case of a mistake, this can be undone by pressing Control-Z) 
 To restart from scratch, select the first level at the bottom 
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It is worth spending a bit of time mastering the Timeline! The Timeline can greatly increase your 

productivity later on. 

  

PhotoEngine also works as a regular application with undo/redo: 

 Press Control-Z or use the Edit > Undo menu to undo a change 
 Press Control-Y or use the Edit > Redo menu to redo 
 To undo several changes press Control-Z several times  

  

Comparing images with the Timeline: 

 Check the Interactive Preview checkbox located at the top of the Timeline panel 
 Move the mouse pointer without clicking over any Timeline levels 
 PhotoEngine immediately update the image with the previous settings 
 By moving the mouse pointer up and down along the Timeline panel you can visually compare 

different image settings 
 By moving the mouse pointer inside and outside of the Timeline panel you can visually compare 

the current settings with a previous one, including the original picture (last line at the bottom of 
the Timeline) 
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Adding a version: 

 Click on a level in the Timeline list to select it 
 Click the Add Version button located at the top of the Timeline panel 

  

 

  

This feature is especially useful for HDR ReLight projects. Use it to record different light setups for a 

given photo.  
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Re-playing the Timeline: 

 Click the Play! button located at the top of the Timeline panel 
 Press the Escape key to stop the animation 

  

 

  

You have worked hard on that project! Enjoy seeing all you changes in one short animation.   
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HDR ReLight: Saving and Exporting 

  

If you plan to work again on the current project, it is critical to save the project as a PhotoEngine project 

file (.rcd file). If you do not plan to work again on the project, you can simply export the final image 

without saving the PhotoEngine project (not recommended). 

  

The PhotoEngine project file (.rcd file) provides the following benefits: 

 Full edition history (Timeline) is saved and restored at next load 
 Nondestructive edition. The PhotoEngine project file contains a reference to your original 

photos: your original photos are never modified by the application 
 Project files are small and are saved instantaneously 

  

Saving the project: 

 Press Ctrl-S or select Save in the File menu 
 The current project file is overwritten with the current settings 
 When the project file is new, a file dialog will appear to allow you to name the project file 

  

 

  

Renaming and saving the project: 

 Press Ctrl-Shift-S or select Save As... in the File menu 
 In the File Dialog, select: PhotoEngine file (*.rcd) 
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 Enter the file name 
 Click the Save button 

  

 

  

  

In order to further edit the image in another tool, to publish it online or other tasks, you need to export 

it in a standard format.  

  

Exporting to TIFF or JPEG: 

 Press Ctrl-Shift-S or select Save As... in the File menu 
 In the File Dialog, select: TIFF (*.tif) or JPEG (*.jpg) 
 Enter the file name 
 Click the Save button 
 Select the TIFF or JPEG settings 
 Click the OK button 
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Direct export to TIFF: 

 Press Ctrl-T or select Export > To Tiff... in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 

  

 

  

Direct export to JPEG: 

 Press Ctrl-J or select Export > To Jpeg... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 
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 Click the OK button 

  

 

  

Exporting directly to an external editor: 

 Press Ctrl-E or select Export To My Tool... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the save settings 
 Click the OK button 

  

 

  

By default PhotoEngine exports to Adobe® Photoshop ®. You can select a different external editor by 

selecting External Editor Preferences... in the Edit menu. 
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To learn more about export options, read: Image Export Options. 
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HDR DeNoise: Creating a Project 

  

Overview 

HDR DeNoise analyzes and merges photos of a scene to reduce the noise level while keeping the details, 

including details in deep shadows. HDR DeNoise is perfect for low light photos and still life photos under 

natural light. 

  

An HDR DeNoise project requires two or more photos. The photos must share the same exposure values 

(shutter speed, aperture and ISO) and the same white balance. Each of the photos should show the 

same scene.  

  

The easiest way to achieve that is to set your camera in burst mode and hold the shutter button. For 

best results take at least four photos. 

  

Creating the project is done in four steps: 

 Step 1: locating the folder containing the photos 
 Step 2: selecting a set of photos 
 Step 3: adding the set to the Project Image Selection panel 
 Step 4: creating the project 
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Step 1, locating the photos 

In order to create a new HDR DeNoise project, you have to first display the photos needed for the 

project in the Browse Workspace. 

  

 

Selecting a folder and displaying the thumbnails: 

 Return in the Browse Workspace 
 Click on the “...” button located in the top Browsing toolbar 
 Using the File Dialog, navigate to the folder containing your photos 
 Click on the Open button 

  

The Browse Workspace now displays the photos contained in the folder you just selected. 
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Step 2, selecting the photos 

  

 

  

Selecting photos: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Click on the first photo in the set 
 Shift-Click on the last photo in the set 

Or: 

 Scroll the thumbnail list until you see the set of photos you want to use 
 Control-Click on each photo 
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A green frame is displayed around the selected photos. 

  

Step 3, adding the photos to the project selection panel 

Add the photos selected at the previous step to the Project Image Selection panel. 

  

Adding photos to the Project Image Selection panel: 

 Select the images as explained in step 2 above 
 Click on the Add button located at the bottom of the Project Image Selection panel 

  

 

  

If the panel already contains photos from a previous project, you have first to clear the Project Image 

Selection list. 

  

Removing all photos from the Project Image Selection panel: 

 Click the Clear button located at the bottom of the Project Image Selection panel 

  

Removing one photo from the Project Image Selection panel: 

 Click on one of the small thumbnails located in the Project Image Selection list 
 Click on the Remove button located at the bottom of panel 
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You are now ready to create an HDR DeNoise project. 

  

Step 4, creating the HDR DeNoise project 

At this point, PhotoEngine can create the HDR DeNoise Project. The HDR DeNoise panel should display: 

“Ready to create HDR DeNoise Project!” 

  

 

  

HDR DeNoise projects have one options: Auto Align. 

  

What is Auto Align? 

If you are not using a tripod the camera may move when bracketing. The Auto Align feature attempts to 

align the photos when assembling the images. 

  

When to use Auto Align? 

Use Auto Align only when taking photos handheld. Never use Auto Align when using a tripod. The 

additional processing always slightly degrades the resulting image. For high quality results, use a tripod 

and turn Auto Align off. 

  

Enabling Auto Align: 

 Click on the Auto Align checkbox located in the HDR DeNoise panel 
 Click again on the checkbox to turn it off 
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After choosing the HDR DeNoise option, you are ready to create the project. 

  

Creating the HDR DeNoise project: 

 Click the Create HDR DeNoise Project button located at the bottom of the HDR DeNoise panel 

  

PhotoEngine automatically switches to the Edit Workspace and starts loading the photos. 

  

What to do when the HDR DeNoise panel displays an error message? 

If your photos do not contain Exif data or have missing Exif data, the HDR DeNoise Panel will display an 

information message such as: “Shutter speed values are required to build an HDR DeNoise Project”. 

  

When this happens you can enter missing data by hand. The Project Image Selection panel works like a 

small spreadsheet. You can click in any cells to enter a missing value. 

  

Manually setting missing data: 

 Click in the cell with the missing value in the Project Image Selection panel 
 Type the missing Shutter Speed, F-Number or ISO value 
 Press the Tab key to validate 
 Repeat until all missing values are entered 
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HDR DeNoise: Editing a Project 

  

Overview 

To learn how to create an HDR DeNoise project read the previous chapter. After creating or loading a 

project, the image is displayed in the Edit Workspace with default settings. 

  

 

  

When editing an HDR DeNoise project the Edit Workspace contains three main areas: 

 1:  the Timeline panel on the left of the screen  
 2:  the edited image 
 3:  the image settings on the right 

  

To edit the image simply click and drag the various sliders located in the right panels. PhotoEngine 
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automatically updates the image in real-time. 
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HDR DeNoise: the Natural HDR Mode 

  

Overview 

The Natural HDR Mode is the result of years of research in Tone Mapping, image processing, color 

theory and psychophysiology. This feature is unique to Oloneo PhotoEngine. Unlike other products, the 

Natural HDR Mode is not just based on mathematical algorithms. It is a mix of sophisticated algorithms 

and empirical corrections based on how humans perceive color, brightness and contrast. 

  

In order to get always the most natural results, the Natural HDR Mode is actually built-in PhotoEngine 

and always running.  The Natural HDR Mode checkbox allows you to turn the effect entirely on or 

partially off. 

  

Using the Natural HDR Mode 

  

Enabling or disabling the Natural HDR Mode: 

 Click on the Enable checkbox located in the Natural HDR Mode panel 

  

 

  

When to use the Natural HDR Mode? 

Most images can benefit from the Natural HDR Mode when you are looking for a natural result. 

  

Natural HDR Mode and Raw processing: 

The Natural HDR Mode combined with light Tone Mapping can have a dramatic effect on your Raw 

photos. Try it, you won’t be disappointed! 

  

When not to use the Natural HDR Mode? 
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Turn it off when you want to create images with very high contrast and saturation. 

  

When working with Raw photos of monochromatic scenes or with muted colors, the Natural HDR Mode 

may apply too strong a correction. 

  

How come the Natural HDR Mode has no effect on my photo? 

The effect is highly dependent on the photo and the settings you are using. PhotoEngine may find that 

the particular setting and photo you are using do not need a correction to look natural. Also, the effect 

can be quite subtle and imperceptible at first glance. The Natural HDR Mode is usually more obvious on 

photos with saturated colors and fairly high Tone Mapping settings. 

  

  



Oloneo PhotoEngine 

 

137 

HDR DeNoise: Image Settings 

  

Low Dynamic Tone settings 

The Low Dynamic Tone panel allows you to edit general image settings: Brightness, Contrast, Saturation 

and White Balance. 

  

Editing key image settings: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Click and drag the Exposure, Brightness, Contrast and Saturation sliders. 
 For high precision edition, hold Control-Key while dragging a slider. 

  

 

  

Editing white balance: 

 Scroll the panels located on the right of the screen to display the Low Dynamic Tone panel 
 Use the Temperature, Tint sliders, Color Wheel or the Illuminant local menu. 
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Setting white balance with the Eye Dropper: 

 Click on the Eye Dropper icon located in the top tool bar 
 Click anywhere in the picture to set the neutral point. 
 When done, click again on the Eye Dropper icon to turn it off 
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HDR DeNoise: Advanced Image Settings 

  

Photographic Print Toning 

Photographic Print Toning simulates a chemical process that replaces the silver contained in the photo 

emulsion by a toner or another metal. This process usually adds two tones to black and white 

photographic prints: one for the deep shadows and one for the highlights. Popular print tonings are: 

sepia, selenium, gold and platinum. 

  

Unlike the real world process, the Photographic Print Toning in PhotoEngine can also work with color 

photos. 

  

Enabling Photographic Print Toning: 

 Scroll the panels located on the right of the screen to display the Photographic Print Toning 
panel 

 Click on the Enable checkbox located at the top left of the panel 
 Click again to disable 

  

 

  

Editing shadow and highlight tones: 

 Click and drag the horizontal slider of the left Color Wheel slider to set the shadow tone hue 
 Click and drag the circular slider of the left Color Wheel slider to set the shadow tone hue 
 Click and drag the horizontal slider of the right Color Wheel slider to set the highlight tone hue 
 Click and drag the circular slider of the right Color Wheel slider to set the highlight tone hue 
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First set the Saturation slider to zero to simulate the regular print toning of a black and white photo. The 

Saturation slider is located in the Load Dynamic Panel. 

  

Editing shadow and highlight Mix: 

 Drag the Mix slider located at the bottom of the panel 

  

 

  

The Mix value defines the balance between shadow and highlight toning. When Mix has a negative 

value, most of the image is toned with the shadow tone.  When Mix has a positive value, most of the 

image is toned with the highlight tone. 

  

  

Brightness Curve 
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The Brightness Curve is a powerful tool. Use it to fine tune the shadow, mid and highlight tones of your 

image. 

  

Editing the brightness curve: 

 Scroll the panels located on the right of the screen to display the Brightness/Brightness curve 
 Click anywhere in the curve to add a new point 
 Drag a point or a tangent (arrow) to change the shape of the curve. 
 To delete a point, click on a point and press the Delete-key or right-click and select Delete 

Selected Point 

  

 

  

Trick: 

If you want to work on the shadows only, add one or two points to the middle and top portions of the 

curve. This will lock the upper part of the curve. Do the reverse when working on the highlights. 

  

  

Saturation Curve 

The Saturation Curve is a unique feature of PhotoEngine. Conceptually, it works like a regular brightness 

curve but in the saturation domain. The input is the original saturation of the image (horizontal axis). 

The output is the edited saturation (vertical axis). The shape of the curve determines how the input 

saturation is mapped to the output saturation. 
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The bottom left of the curve controls the pixels with a low saturation; the upper right portion controls 

pixels with a high saturation. Here is an example: 

 Click on the middle of the curve to add a point 
 Drag the top right tangent to an horizontal position 
 Drag the top right point to the bottom 

  

The shape of the curve (see screen shot below) now maps highly saturated pixels to de-saturated ones. 

This means that saturated pixels are now in black and white. 

  

By editing other sections of the curve, you can selectively saturate or de-saturate portions of the edited 

image. 

  

Editing the saturation curve: 

 Scroll the panels located on the right of the screen to display the Saturation/Saturation curve 
 Click anywhere in the curve to add a new point 
 Drag a point or a tangent (arrow) to change the shape of the curve. 
 To delete a point, click on a point and press the Delete-key or right-click and select Delete 

Selected Point 
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Color Equalizer 

The Color Equalizer works just like an audio equalizer. Instead of modifying bass or treble, it acts on the 

various hues of the edited photo. The Color Equalizer can create a large range of effects. Here are a few 

examples: 

 Decrease the brightness of a blue sky without affecting the other colors of the photo 
 Slightly de-saturate a lawn that appears too green (a common occurrence) 
 Convert a photo to black and white except for objects with a red hue. 
 Shift the color of car from blue to red 

  

The Color Equalizer is split into three parts: 

 Hue/Saturation 
 Hue/Luminance 
 Hue/Hue 
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Hue/Saturation: 

Use the Hue/Saturation curve to increase or decrease the saturation of pixels with a given hue. 

  

Hue/Luminance: 

Use the Hue/Luminance curve to increase or decrease the luminance of pixels with a given hue.  

  

Hue/Hue: 

Use the Hue/Luminance curve to shift the pixels with a given hue to another hue, such as orange to red, 

blue to green, etc. 

  

Editing the Hue/Saturation curve: 

 Scroll the panels located on the right of the screen to display the Hue/Saturation curve 
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 Drag a point vertically to change the shape of the curve. 

  

 

  

The Hue/Luminance and Hue/Hue curves work the same way. 

  

To learn more about curve edition, read: User Interface Main Controls. 

  

Comment: 

The Color Equalizer is also a powerful tool to convert a photo to black and white. The process is as 

follows: 

 First set the Saturation slider to zero to convert to black and white 
 Use the Hue/Luminance curve to increase or decrease the luminance based on the original color 

  

With this approach you can, for instance, darken a blue sky in a black and white photo. 
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HDR DeNoise: the Timeline 

  

As with all PhotoEngine projects, everything you do is automatically recorded in the Timeline panel 

located at the left of the screen. You can click on a Timeline level to go back in time and see the image at 

a previous step of the edition process. 

  

 

  

The Timeline is saved in the PhotoEngine project files (.rcd). Your changes are never lost. By reloading 

the project file later on, you will recover all your edition history. 

  

Selecting a previous level in the Timeline: 

 The latest change is displayed at the top of the Timeline list 
 The original image is displayed at the bottom of the list 
 Click anywhere in the list to restart from a previous step. All steps above the selected level will 

be deleted at the next change (in case of a mistake, this can be undone by pressing Control-Z) 
 To restart from scratch, select the first level at the bottom 
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It is worth spending a bit of time mastering the Timeline! The Timeline can greatly increase your 

productivity later on. 

  

PhotoEngine also works as a regular application with undo/redo: 

 Press Control-Z or use the Edit > Undo menu to undo a change 
 Press Control-Y or use the Edit > Redo menu to redo 
 To undo several changes, press Control-Z several times 

  

Comparing images with the Timeline: 

 Check the Interactive Preview checkbox located at the top of the Timeline panel 
 Move the mouse pointer, without clicking, over any Timeline levels 
 PhotoEngine immediately updates the image based on the level’s settings 
 By moving the mouse pointer up and down along the Timeline panel you can visually compare 

different image settings. 
 By moving the mouse pointer inside and outside of the Timeline panel you can visually compare 

the current settings with a previous one, including the original picture (last line at the bottom of 
the Timeline). 
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Adding a version: 

 Click on a level in the Timeline list 
 Click the Add Version button located at the top of the Timeline panel 

  

 

  

Re-playing the Timeline: 

 Click the Play! button located at the top of the Timeline panel 
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 Press the Escape key to stop the animation. 

  

 

  

You have worked hard on that project! Enjoy watching all your changes in one short animation. 
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HDR DeNoise: Saving and Exporting 

  

If you plan to work again on the current project, it is critical to save the project as a PhotoEngine project 

file (.rcd file). If you do not plan to work again on the project, you can simply export the final image 

without saving the PhotoEngine project (not recommended). 

  

The PhotoEngine project file provides the following benefits: 

 Full edition history (Timeline) is saved and restored at next load 
 Nondestructive edition. The PhotoEngine project file contains a reference to your original 

photos: your original photos are never modified by the application 
 Project files are small and are saved instantaneously 

  

Saving the project: 

 Press Ctrl-S or select Save in the File menu 
 The current project file is overwritten with the current settings 
 When the project file is new, a file dialog will appear to allow you to name the project file 

  

 

  

Renaming and saving the project: 

 Press Ctrl-Shift-S or select Save As... in the File menu 
 In the File Dialog, select: PhotoEngine file (*.rcd) 
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 Enter the file name 
 Click the Save button 

  

 

  

  

In order to further edit the image in another tool, to publish it online or other tasks, you need to export 

it in a standard format.  

  

Exporting to TIFF or JPEG: 

 Press Ctrl-Shift-S or select Save As… in the File menu 
 In the File Dialog, select: TIFF (*.tif) or JPEG (*.jpg) 
 Enter the file name 
 Click the Save button 
 Select  the TIFF or JPEG settings 
 Click the OK button 

  



Oloneo PhotoEngine 

 

152 

 

  

Direct export to TIFF: 

 Press Ctrl-T or select Export > To Tiff... in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 

  

 

  

Direct export to JPEG: 

 Press Ctrl-J or select Export > To Jpeg... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 



Oloneo PhotoEngine 

 

153 

 Click the OK button 

  

 

  

Exporting directly to an external editor: 

 Press Ctrl-E or select Export To My Tool... in the File menu 
 Enter the file name 
 Click the Save button 
 Select the save settings 
 Click the OK button 

  

 

  

By default PhotoEngine exports to Adobe® Photoshop ®. You can select a different external editor by 

selecting External Editor Preferences... in the Edit menu. 
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To learn more about export options, read: Image Export Options. 

  

  



Oloneo PhotoEngine 

 

155 

Export Options 

  

Overview 

When you are done with your image editing, it is time to export your work in a standard image file 

format. Exporting the image allows you to further edit the image in another tool, to publish it online or 

other tasks. 

  

PhotoEngine can export images in the JPEG and TIFF formats. 

  

Exporting to JPEG 

The JPEG should only be used when exporting an image for web publishing. Use the TIFF format if you 

plan to archive your image or edit it in another tool. 

  

Exporting to JPEG: 

 Press Ctrl-J or select Export > To Jpeg… in the File menu 
 Enter the file name 
 Click the Save button 
 Select the JPEG settings 
 Click the OK button 
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During the export process PhotoEngine displays the JPEG Options dialog. 

  

 

  

Selecting the Color Space: 

 Click the Color Space menu 
 Select the sRGB, Adobe RGB or ProPhoto RGB option 

  

As JPEG is an 8-bit file format, it is recommended to only use the sRGB or Adobe RGB color space. 

  

Selecting the Resolution: 

 Enter the resolution 
 Select the pixels/inch or pixels/cm unit 

  

The Resolution does not change the image pixel size (the width and height remains unchanged). The 

resolution sets the physical size of the printed image. 

  

Selecting the Quality: 
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 Click and drag the Quality slider 

  

The Quality defines the level of compression of the JPEG file. The lower the value, the lower the file size 

will be. It is recommended to use a value of 80 or higher for an adequate quality. 

  

Setting the Artist Info: 

 Check the Add Artist Info checkbox to add your name and copyright to the image file 
 Enter your name 
 Enter your copyright 

  

The copyright and artist name data are stored in the relevant image Exif fields. 

  

Exporting to TIFF 

The TIFF format is the recommended file format for exporting images from PhotoEngine. TIFF images are 

using a lossless compression method that entirely preserves the image quality. 

  

If you plan to edit the image in another tool, the recommended settings are: 

 Color space: ProPhoto RGB 
 Bit Depth: 16-bit 
 Compression: None or LZW (both methods are lossless) 

  

Exporting to TIFF: 

 Press Ctrl-T or select Export > To Tiff… in the File menu 
 Enter the file name 
 Click the Save button 
 Select  the TIFF settings 
 Click the OK button 
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During the export process PhotoEngine displays the TIFF Options dialog. 

  

 

  

Selecting the Color Space: 

 Click the Color Space menu 
 Select the sRGB, Adobe RGB or ProPhoto RGB option 
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Selecting the Resolution: 

 Enter the resolution 
 Select the pixels/inch or pixels/cm unit 

  

The Resolution does not change the image pixel size (the width and height remains unchanged). The 

resolution sets the physical size of the printed image. 

  

Selecting the Compression: 

 Click the Compression menu 
 Select the LZW or None option 

  

Setting the Artist Info: 

 Check the Add Artist Info checkbox to add your name and copyright to the image file 
 Enter your name 
 Enter your copyright 

  

The copyright and artist name data are stored in the relevant image Exif fields. 
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Color Management 

  

Overview 

Oloneo PhotoEngine is a fully color managed application. From input to output, PhotoEngine keeps track 

of the various color spaces used and automatically applies the required color transformations. The 

application also converts the displayed image using your display color profile. PhotoEngine is compatible 

with most ICC files created by display calibration devices. 

  

Display Preferences 

By default, PhotoEngine automatically locates and uses your display color profile. You can turn off this 

feature or choose a custom color profile. Unless you have specific reasons to do so, you should not 

modify the display color profile settings. 

  

 

  

Showing the Display Color Profile Settings dialog: 
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 Select Display Preferences... in the Edit menu 

  

Turning off display color management: 

 Open the Display Color Profile Settings dialog 
 Check the Use sRGB Color Space button 
 Click the OK button 

  

Using a custom display color profile: 

 Open the Display Color Profile Settings dialog 
 Check the Use Custom ICC Profile button 
 Click the Browse... button 
 Select an ICC file 
 Close the file dialog 
 Click the OK button 

  

Restoring the default display color management: 

 Open the Display Color Profile Settings dialog 
 Check the Use Monitor Color Profile button 
 Click the OK button 
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External Editor Preferences 

  

Oloneo PhotoEngine can export the edited image to an external image editing tool. By default 

PhotoEngine exports to Adobe® Photoshop®.  

  

 

  

Selecting an external editing tool: 

 Select External Editor Preferences... in the Edit menu 
 Click the Choose... button 
 Select an application (.exe) 
 Close the file dialog 
 Click the OK button 

  

Choosing the export file format: 

 Select External Editor Preferences... in the Edit menu 
 Click the File Type menu 
 Select TIFF or JPEG 
 Click the OK button 
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Adobe Lightroom plug-in 

  

Overview 

Oloneo PhotoEngine includes a plug-in for Adobe® Photoshop® Lightroom®. The plug-in allows you to 

select images in Lightroom and send them to PhotoEngine for editing. The images can be pre-processed 

by Lightroom. 

  

The plug-in runs with: 

 Lightroom 2.7 and higher 
 Lightroom 3.4 and higher 

  

Enabling the plug-in 

Before using the plug-in, you have to enable it in Lightroom. The Lightroom plug-in is installed in the 

Oloneo PhotoEngine folder located in “My Documents”. 

  

Enabling the plug-in: 

 Start Lightroom 
 Select Plug-In Manager... in the File menu 
 Click the Add button 
 Navigate to My Documents/Oloneo PhotoEngine/LRPhotoEngine.lrplugin 
 Click OK 
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Locating PhotoEngine.exe: 

 Start Lightroom 
 Select Plug-In Manager... in the File menu 
 Click on LR/PhotoEngine in the list located at the left of the Manager dialog 
 Click on the Choose... button located in the Configuration panel 
 Navigate to C:\Program Files\Oloneo PhotoEngine\PhotoEngine.exe 
 Click Select button 
 Click Done 

  

The Lightroom plug-in is now ready to use. 

  



Oloneo PhotoEngine 

 

165 

 

  

  

Using the plug-in 

In order to use the plug-in you have first to add photos to the Lightroom Library. Please refer to the 

Lightroom manual to learn how to add photos to the Library. When done, select in the Library the 

photos or the Stack you want to send to PhotoEngine. 

  

Starting the plug-in: 

 Select Plug-in Extras in the File menu 
 Select Send Exposures to Oloneo PhotoEngine... 
 The plug-in dialog is shown 
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Selecting the Project type and options: 

 Click the Project Type menu, select HDR ToneMap, HDR ReLight or HDR DeNoise 
 Select the project options such as Autoalign and Ghost Removal 

  

Read the previous chapters to learn more about HDR ToneMap, HDR ReLight and HDR DeNoise. 
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Selecting the files to send 

 Click the Image Files To Send menu 
 Select Original Files or Images with Lightroom Adjustments  

  

The Original Files option sends the files to PhotoEngine without any modification. The Images with 

Lightroom Adjustments option applies Lightroom pre-processing (such as: Raw processing, noise 

reduction, lens corrections) and then sends the images to PhotoEngine. 
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Set the stack option 

 Check or uncheck the Send Entire Stack 

  

Lightroom sends to PhotoEngine all the images contained in a selected Stack when this option is 

checked. 
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Sending the images 

 Click the Send Images button 
 PhotoEngine starts and loads the images 
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Plug-in Export Presets 

To accelerate you work, you can create export presets in the Lightroom plug-in. 

  

Managing Export Presets 

 Select Plug-in Extras in the File menu 
 Select Send Exposures to Oloneo PhotoEngine... 
 Click in the menu located at the top of the plug-in dialog 
 Select Save Current Settings to create a new preset 
 Select a previously saved preset to use default export settings 
 Select Delete to delete a preset 
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Legal Notices 

  

© Copyright Oloneo 2011. 

  

Oloneo, the Oloneo logo, Oloneo PhotoEngine, HDR ReLight, HDR ToneMap, HDR DeNoise, Color Curve 

Equalizer and Natural HDR are either registered trademarks or trademarks of Oloneo SAS. 

  

Adobe, the Adobe logo, Lightroom and Photoshop are either registered trademarks or trademarks of 

Adobe Systems Incorporated in the United States and/or other countries.  

  

All other trademarks belong to their respective owners. 
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